Related Pages

RSS Feed Knowledge Base Feed

Page Options
Twitter:
Sponsor:


Mailbox unavailable. The server response was: 5.7.1 Unable to relay with Microsoft Exchange

Problem Description:

When trying to send email via SMTP with an exchange server you get the message "Mailbox unavailable. The server response was: 5.7.1 Unable to relay".

You may also get a message saying that you are unable to email as that user, or email address. Another issue is that you will get a message saying you are unable to send to that recepient.

This is most commonly noticed by web applications, and programmers using the .Net framework.



Cause of the Problem:

Microsoft Exchange does not allow anonymous email relaying, or sending mail outside of the domain without authorization by default. This is done to prevent servers from being turned into spam relay servers.



Advertisement:
Your Ad Here

Resolution/Fix:

First make sure you are providing credentials to the SMTP server your are attempting to send mail with, and that they are correct.

If your credentials are correct and there are no issues, then try adjusting the security on your exchange connector. It is also recommended to setup a special email relay connector just for this purpose, that does not allow connections from outside your network.

Open the Exchange management shell and run the following commands to grant the user permission to send email anywhere through a receive connector. Remember to replace "Name of connector" with your connector name, and "DOMAIN\Login" with your domain and user name.

These four permissions grant the ability to send email via SMPT, allows it to send to any person, allows it to send as any person, and last allows you to send as another user over the network or between domains.

 





Related Programs and Devices:
.Net Framework , Microsoft Exchange , SMTP Server , Relay Server

Last Updated: 01/15/2010 02:49 PM

blog comments powered by Disqus